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INSTRUCTION of countPHICS 
(count & Plot HIstograms of Colony Size) 
 
1. INTRODUCTION 
 
countPHICS is a program that analyses images of cell colonies located on a cell culture 
dish. It counts the number of colonies and examines statistical distribution of their size. 
 
2. SYSTEM REQUIREMENTS 
 
countPHICS is dedicated for Windows 7, 8, 10 platforms (64-bit). 
 
3. IMAGE REQUIREMENTS 
 
3.1 Format 
 
countPHICS supports the same file formats as the ImageJ program. A list of formats 
can be found here: 
 
http://imagejdocu.tudor.lu/doku.php?id=faq:general:which_file_formats_are_supporte
d_by_imagej 
 
However to obtain size of colonies in SI units, information about pixel size must be 
embedded in the image information. Therefore, TIFF is the recommended format. 
 
3.2 Resolution 
 
Plates have to be scanned in colour mode, grey scale pictures will not work since this 
software uses the RGB colours during analysis. The higher resolution, the better 
accuracy is provided with countPHICS. It is not recommended to use images with a 
resolution below 200 DPI. While larger images (e.g. 1200 DPI) give better results, they 
cause the program to execute slower (this might be a problem only on slow computers). 
 
3.3 Image quality 
 
At the end of the document some sample images are shown with further description of 
their potential performance. 
The general rule is to keep the image uniform, i.e. with the same intensity of 
background in the whole image. The higher contrast between the colonies and the 
background, the easier it is for countPHICS to locate them. In case images are acquired 
with a camera and not a scanner, photos should be taken perpendicularly to the dish 
surface to minimise the area where colonies overlap the dish edges. 
 
3.4 Processing multiple images 
 
Sometimes the scanned image consists of many single dishes which can be split into 
single pictures. It can be done with IrfanView software (available from 
http://www.irfanview.com) according to the instruction given for the 6-well plate 
below:  
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• Open the scanned file: File → Open;   

• Rotate the file: Image → Rotate Right/Left (depending on your scanner);   

• Split into two rows and three columns: Options → Export image tiles (split image) 
as it’s shown in figure below; 

    

• Choose the place where you want to save the results: Browse and click Start.   

 

As a result you will have six files with the names including information of their position 
(e.g. [Untitled]001 2x3.jpg means that it is the plate in the second row and the third 
column). The next step is to convert the files into TIF files and rename them as: 1.tif, 
2.tif, 3 tif,..., respectively. To do that the IrfanView can be used again:  

1. Choose from the menu: File → Batch Conversion/Rename... (batch conversion 
window appears as in figure below);   

2. Choose Batch conversion - Rename result files (the third option in the left top 
corner), then TIF format and the name pattern ( # - only one hashtag sign);   

3. Going down still on the left side choose the place where you want to save the 
results by clicking Browse;   

4. On the right side you can choose the directory where your files are located and 
mark those interesting for you;   

5. Use the button Add or Add all to add them to the window in the bottom right 
corner;   

6. Eventually you can click Start Batch (left bottom) and close the window clicking 
Exit batch;  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3.5 File name 
 
There are specific terms of file naming. Two conventions are available: 
 
a) ImageNumber_filename.format e.g. 1_experiment.TIF, 13_OldExp.TIF etc. 
 
or simply: 
 
b) ImageNumber.format e.g. 1.TIF, 2.TIF … 99.TIF etc. 
 
Other file naming conversions will NOT work. 
 
It is extremely important to write all file names with the descriptive information into an 
excel file which can be used as a legend. All plates should be described there and the 
information about their localisation (the name of the folder and file names) of all photos 
should be included. The excel file can be used later for copying the results from ImageJ 
and final analysis of the data.  

 
 
3.6 Single image or 6-well plate image 
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countPHICS supports one single dish or 6-well plate per image. 6-well plate should be 
3x2 well axis as illustrated below. When using images of 6-well plates, it is important 
that they are cropped along the outer well edges to ensure symmetrical localisation of 
each well in the image.  
 

 
 
 
 
4. CREATING A DESKTOP SHORTCUT (optional) 
 
In order to create desktop shortcut to countPHICS follow these steps: 
 
1. Right click on desktop and select New → Shortcut 
2. A new window will open. Select Browse, find the countPHICS.bat in your 
countPHICS directory and then click OK. 
3. In the new window, click Finish. 
 
The shortcut is ready, but you can also add a proper icon: 
 
4. Right click on the shortcut and choose Properties 
5. Choose Shortcut tab and click Change icon… 
6. Click OK in the new window. 
7. Click Browse and find icon.ico. Select the file and click Open. 
8. Click OK in both windows. The shortcut with the new icon is now ready. 
 
5. USING countPHICS 
 
In order to run countPHICS double-click the countPHICS.bat file located in the main 
directory, or use the desktop shortcut if it has been created. The following window will 
appear: 
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In order to run only the colony counting part, check the first checkbox. In order to run 
size distribution analysis check the second checkbox. You can check both of them at 
the same time; in this scenario, once data is collected from the colony counter, the 
window for the size distribution analysis will automatically open. The text files 
containing colony size data will be saved, but you can still decide to perform the size 
analysis at a later time point. 
Once the options are chosen click Start. 
 
5.1 Instruction of Colony counter 
 
Once Start is clicked the program loads the ImageJ macro counter.txt. Depending on 
computer performance it may take a while, from a few seconds to even 1-2 minutes. 
Once the ImageJ is opened it may ask you for an update. This will generally happen 
only at the first program usage on each computer. In this case simply accept the update. 
It is recommended to shut down the ImageJ after that and use the Start button once 
again. A new window will pop up: 
 

 
 
To select images from your computer, use the Select FIRST image button, then navigate 
to an image file which should be analysed. Colony counter is able to analyse a series of 
images located in a folder. If you want to use this option always select the image with 
the lowest number first.  
 
Select output directory is an additional button that lets the user choose the output data 
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directory. If not specified, data will be saved in the output_data folder located in your 
countPHICS directory. 
 
Once image and data directory are chosen click OK. The next window will pop up: 
 

 
 
The user is asked to choose settings. Each of them are described below: 
● Automatic Threshold – if checked, the image will convert to a binary (black-

and-white) picture automatically. This option results in a slightly lower 
accuracy in most cases but it is recommended for inexperienced users. If 
Automatic Threshold is not selected, a manual threshold adjuster will be used. 
During the program execution the following windows will pop up: 
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Adjust the scrollbar (checked in the green box) to obtain the desired effect. All colonies 
should be marked with red colour and at the same time background should not be 
marked at all. Some examples of correct threshold-adjusted images are showed at the 
end of the instruction (section 7).  
● Same region of interest (ROI) for all images – this option is useful if a series 

of images are processed. It is recommended to fit the ROI to each image one by 
one, but if the dish is located at the same spot on each image and you want to 
speed up the analysing process this option can be used.  

● 6-well plate – it should be checked if 6 in 1 images are analysed.  
● Advanced settings – An advanced settings window will pop up. Usually this is 

not recommended because default parameters are optimised to give the best 
results. However sometimes it might be needed to choose parameters manually 
because every image is different.   
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 Rolling ball radius is the radius of curvature of the paraboloid. As a rule of 
thumb, for 8-bit or RGB images, it should be at least as large as the radius of the largest 
object (given in pixels) in the image that is not part of the background. Larger values 
will also work unless the background of the image is too uneven.  
Visit http://imagejdocu.tudor.lu/doku.php?id=gui:process:subtract_background for 
more information. 
 

Minimum colony size is the area (given in pixels) of the smallest object to 
analyse. Objects with size below this value will not be counted. 
   
 Circularity is a value between 0 and 1. By default it is set to 0.5. The higher 
the value, the more strict is the ‘round shape’ for colonies to be analysed.  
For more information visit: 
http://imagejdocu.tudor.lu/doku.php?id=gui:analyze:analyze_particles 
 
 Sigma is the standard deviation of the Gaussian blurring filter. It is chosen as 
default depending on the image resolution. More details can be found here: 
http://imagejdocu.tudor.lu/doku.php?id=gui:process:filters&s[]=sigma 
 
 
Once all the settings are chosen the user is asked to fit the ROI to the image. 
 

 
 
If ROI disappears Recreate ROI button can be used to show it again. ROI should not 
include dish edges and at the same time it should enclose as many colonies as possible. 
Some examples are given below. 
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Once the ROI is fit, click OK. 
 
The result file which is created now in your output_data folder is called: 
ImageNumber_filename.txt. In case of 6-well plate images the numbering system is 
shown below: 
 

 
 
 
The output files consist of the analysed image name, colony numbers and colony sizes 
given in mm2. 
 
 
5.2 Instruction of PHICS (Plot HIstograms of Colony Size) 
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The program menu consists of File, Fit and Help modules. 

File: 

With the File module you can open a file with colony size data (Open), then press Plot 
to show the histogram. Within this module you can also save the plot as PNG (Save 
PNG) and PDF format (Save PDF). 

After you plot the histogram you can change the range of X axis setting xmin and xmax 
values. To create histograms the entire range of data should be divided into non-
overlapping intervals called bins. It is possible to plot histograms with different number 
of bins by changing the number of bins in the designated place. The width of the bin is 
calculated as (xmax-xmin)/No. of bins. To visualize your changes the Plot button (right 
bottom corner) should be clicked. 

Fit: 

To fit a function to your data choose Fit module from the program menu. There are two 
functions available at the moment: Gaussian and Weibull (recommended) distributions. 
The chosen function (listed in Fit module) will be fitted using parameters from the 
equations below. The least square method is used to fit and the distributions are 
described by the equations: 

Gaussian distribution:	

𝑓(𝑥) =
1

√2𝜋 ∙ 𝜎
∙ exp	(−

(𝑥 − 𝜇)2

2 ∙ 𝜎2 )	

where µ is a mean value and s - standard deviation. 

Weibull distribution is described as follows: 

𝑓(𝑥) = 𝑐 ∙
𝑎
𝑏6 ∙ 𝑥

678 ∙ exp	(−(
𝑥
𝑏)

6)	

 
where x is colony size, c is an amplitude, a and b – Weibull’s parameters which are 
needed to calculate the mean size value and standard deviation (displayed in the figure 
as µ and s, respectively). 

Help: 

To open this instruction click Open instruction, to close it - click the Quit button (right 
top corner). 

Some definitions: 

Bin – the interval of values with a given width including a certain amount of data, the 
width is calculated as (xmax -xmin)/(no. of bins)  

xmin – minimal value of the X-axis (the minimal colony size) plotted in the histogram 

xmax – maximal value of the X-axis (the maximal colony size) plotted in the histogram 



	

	 11	

µ – mean value fitted from the chosen distribution 

s – the standard deviation 

We recommend to analyse control plates first, and then use the same parameters (xmin, 
xmax and no. of bins) for all samples that should be processed. 
 

 
 
6. Image examples 
On the next pages some example images are shown. 
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Image 

    
Description 

 

Almost perfect image. 
Some colonies are hidden 
behind the “dish edge”. 
    
   

 

 

Overall good image, but 
the downside are too 
many colonies behind the 
dish edge, and shades 
created by colonies (the 
program might count 
them as additional 
colonies). 
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Good image, but be 
careful! Once the 
resolution is too low 
colonies might disappear 
during the analysing 
process (binary erosion). 
    
   

 

 

Colonies are in a large 
conglomeration. It is 
difficult to count them in 
both ways: manually and 
automatically. Difficult 
image. 
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The stain is not strong 
enough, the contrast is too 
low. The program will 
still count the colonies but 
less efficiently.  
   
   
   

 

 

Colonies are too small and 
they might disappear 
during the binary erosion 
operation. 
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7. Threshold tips 
 
Threshold value is too low. Some colonies are not marked (green circles). 

 
 
 
Threshold value is too high. Artefacts appear (green circles). 
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Threshold value is just fine! 
 

 

 


